Difference between revisions of "Getting Started"

From DLS5 Wiki
Jump to: navigation, search
(Prerequisites)
Line 2: Line 2:
 
__TOC__<BR>
 
__TOC__<BR>
 
'''''NOTE:''' For Security system compatability, see the list of [[Supported Panels]]''
 
'''''NOTE:''' For Security system compatability, see the list of [[Supported Panels]]''
 +
 +
== End User License Agreement ==
 +
[[DSC Software EULA|DSC Software End User License Agreement]]
  
  

Revision as of 08:27, 27 July 2010


NOTE: For Security system compatability, see the list of Supported Panels

End User License Agreement

DSC Software End User License Agreement


Supported Operating Systems

  • Windows XP Professional with Service Pack 3 or higher
  • Windows XP Professional with Service Pack 2, Windows Installer 3.1, and kb926255 Windows updates installed
  • Windows Vista


To determine what service pack version of Microsoft XP Professional you are running and if the kb926255 Windows Update is installed follow this link


Prerequisites

The following applications must be installed for DLS IV to operate.

1) Microsoft .NET Framework v3.5 SP1

2) Microsoft SQL Express 2005 SP3

Version 9.00.4035

3) Microsoft Visual C++ 2008 Runtime (x86)

During the installation process, DLS IV detects any missing applications and automatically installs them for you. However, to speed up the DLS IV installation process or if you are having trouble with the automated installation of prerequisites, these applications may be installed manually by the user before starting the DLS IV installation. They must be installed in the order listed below.

1) Windows Installer v3.1

http://www.microsoft.com/downloads/details.aspx?FamilyID=889482FC-5F56-4A38-B838-DE776FD4138C


2) Microsoft .NET Framework v3.5 SP1

http://www.microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7


3) Microsoft SQL Express 2005 SP3

Version 9.00.4035
http://www.microsoft.com/downloads/details.aspx?FamilyID=3181842a-4090-4431-acdd-9a1c832e65a6


4) Microsoft Visual C++ 2008 Runtime (x86)

http://www.microsoft.com/downloads/details.aspx?FamilyID=9b2da534-3e03-4391-8a4d-074b9f2bc1bf


Any critical updates to these prerequisites should be installed via Windows Update.

Minimum System Requirements

To support the prerequisites for DLS IV the following system requirements must be met:

  • Processor: 600 megahertz (MHz) Pentium III compatible or faster processor - 1 gigahertz (GHz) or faster is recommended
  • RAM: 1GB of System Memory
  • Hard Disk: Up to 1GB of available space may be required.

Note: DLS uses only 40MB, additional hard disk space may be required for prerequisites.

  • CD or DVD Drive: Not required
  • Display: 1024 x 768 high color, 32-bit (Recommended)

Downloading

Download the DLS IV Updater from The DSC homepage


Installation

DLS IV is built with the future in mind. It runs on Microsoft's powerful .NET Framework 3.5 and MSSQL Express database engine. If you do not currently have these software packages installed, the DLS IV installer will automatically download the latest version directly from Microsoft.com for you and install them without any unnecessary intervention from you, the user.

The installation process begins with the DLS IV Updater. The Updater manages the rest of the installation process for you and will provide updates in the future as DSC rolls out additional driver packs and feature updates.

Here is a brief run-down of the installation steps:

1. Install the DLS IV Updater.

2. The DLS IV Updater installation checks for prerequisite applications (VC++ Runtime, .NET Framwork 3.5, and MSSQL Express).

3. If the .NET Framework 3.5 software is missing, it is downloaded directly from microsoft.com and automatically launched.

4. If the MSSQL Express software is missing, it is downloaded directly from microsoft.com and automatically launched.

5. If Visual C++ Runtime components are missing, they are downloaded directly from microsoft.com and automatically launched.

6. The DLS IV Updater launches and displays the latest available DLS IV products. Choose the DLS IV Engine and any of the available driver packs you need.

7. The selected components are downloaded directly from the DSC FTP site and installed.

8. Close the DLS IV Updater software and start using DLS IV.



Login

The default administrator username/password for DLS IV is:


Username = admin

Password = 1234


It is strongly recommended that you change the Administrator's password immediately after installing DLS IV.